Creating a Virtual Floppy Image on MacOS

Create .flp’s with MacOS

  1. Create an empty file that will ultimately get attached as the virtual floppy in VmWare.
    dd if=/dev/zero of=myfloppy.img bs=1024 count=1440
  2. Attach the image and format it as FAT, without a partition map. hdiutil returns the device file where the image is attached, so we just pass that right into diskutil as the device to be formatted.
    diskutil eraseVolume MS-DOS MYFLOPPY `hdiutil attach -nomount myfloppy.img`
  3. After you’re done, right click the .img and ‘Get Info’ so you can rename it to .flp.

Source: http://thatswhatised.com/blog/post/creating-a-virtual-floppy-image-on-macos

Convert ASM to FLP and ISO

nasm -f bin -o myfirst.bin myfirst.asm
dd status=noxfer conv=notrunc if=myfirst.bin of=myfirst.flp
mkisofs -o myfirst.iso -b myfirst.flp cdiso/

Using mkisofs to create an ISO from a folder on OSX

Quick tip, if you’re wanting to make a CD-style ISO file from a folder.

We can use mkisofs via the command line, to get it you need to install the cdrtools package.

On OSX:
brew install cdrtools

It should be available on other distributions under the same name.

To generate the ISO:
mkisofs -V CDNAME -J -r -o /path/to/output.iso /path/to/folder

 

Sumber:
http://mikeos.sourceforge.net/write-your-own-os.html
https://nertant.com/2017/01/05/using-mkisofs-to-create-an-iso-from-a-folder-on-osx/

 

Preview have an error opening a file: The file “iris_clusters.png” couldn’t be opened because you don’t have permission to view it.

Source:

http://apple.stackexchange.com/questions/209686/preview-refuses-to-open-pdf-file-incorrectly-claiming-a-permission-issue

After searching on the net I found a solution, following mainly this suggestion, though only deleting a small sub-directory:

  1. I removed the sub-directory ~/Library/Containers/com.apple.Preview/Data/Library/Saved Application State/com.apple.Preview.savedState
  2. I quit Preview and re-started it.

Using the Built in TFTP Server on OS X

Sumber:

Using the Built in TFTP Server on OS X El Capitan

OS X Built-in tftp Server

Default tftpd folder: /private/tftpboot
pastikan ada subfolder dengan permission 777 jika perlu menaruh file.

Perintah menjalankan service tftpd:

sudo launchctl load -F /System/Library/LaunchDaemons/tftp.plist
sudo launchctl start com.apple.tftpd

Perintah untuk mematikan layanan tftpd:

sudo launchctl unload F /System/Library/LaunchDaemons/tftp.plist